Announcement

Collapse
No announcement yet.

0.41.4 bugs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 0.41.4 bugs

    Immediate crash when I try to place the "Keg of Ale" I bought from Sally in my manor house.
    edit: It wasn't specifically the keg of ale. Sometime around the time I tried to place it, all furniture decoration actions started producing crashes. That persisted for several days, then fixed itself. No idea why it started or why it stopped. The issue effected multiple manors. The exact error message is "Script 'Furniture system' line 1094: NoMethodError occured. undefined method 'add_lif' for nil:NilClass"

    Also, on the Followers screen, it incorrectly has heart bubbles shown only for followers who are *past* ready to unlock the next heart instead of (more usefully) showing heart bubbles for those are ready to unlock the next heart.
    Last edited by scro; 09-01-2019, 05:38 AM.

  • #2
    Not exactly bugs, but arguably:

    When I select "Save" from the menu, a lot of the times the default slot it goes to is "autosave" instead of the most recent manual save. It's pretty rare for players to want to manually overwrite the autosave, so that could probably use a change.
    edit: Especially since it's not actually *legal* to save over the autosave.

    Way back in the day, like sometime in 0.2x I think, you could hold down the control key during combat to make everything go about twice as fast, except for the animations when someone died. That feature vanished after a while, but at the same time combat got a lot faster and better, so overall I couldn't complain. But now it looks like maybe someone has started to reintroduce the same feature, but left it... very incomplete? If I hold down control on this version in combat during a multitarget spell that doesn't kill anyone then the general spell animation will take place, with sound effect, and the first damage animation w/ sound effect will take place, but after that damage animations will not have any sound effects, and might be a hair faster. But, it's inconsistent, doesn't always work, doesn't speed things up much, and once in a while seems to take effect when I'm not holding the control key down.

    edit: After playing a while longer, on the holding control down in combat thing - I don't think I've seen sound effects skipped when NOT holding control down, but beyond that behavior is very inconsistent. I almost always still get sound effects playing for the first target of a multitarget attack, but only almost always. I sometimes skip the sound for the 2nd target. The 3rd targets sound effect is generally skipped only if the 2nds was skipped, but often it plays anyway even when the 2nd targets sound effect was skipped. Also, the sound effects for dieing enemies do get skipped once in a very rare while, but much less often than for enemies who survive an attack. Also, while fewer sounds get played, I'm not sure combat is actually any faster, so I'm still unsure if this is an attempt to reintroduce the old feature or not.
    Last edited by scro; 09-02-2019, 11:50 AM.

    Comment


    • #3
      Bug: Burning Blizzard (the acid/ice spell), does not consistently count against either cold spells cast or acid spells cast for achievements. Sometimes it counts for both, sometimes it counts for neither, I haven't figured out the exact pattern yet. edit: Tentatively, I believe that if all enemies die from the first element type, then it counts as neither element, but if some survive until the second element is invoked it counts as both elements.
      Last edited by scro; 08-29-2019, 10:59 AM.

      Comment


      • #4
        The icon for "DEF debuffed, stacked twice" is being used for something else in addition, at least when fighting the random kobold battles. I'm not sure what exactly, it looks like something similar, seems to be a side-effect of an acid attack, but it sure seems like something other than the normal use for that icon:
        1. It can be active at the same time as the normal version of the "DEF debuffed" icon. Meline has both as I type this.
        2. It comes in one hit, despite having the two downward arrows in it.
        3. It persists after the end of battle, though not for terribly long.
        4. In the battle log, the line for when Meline acquired this is just "Kobold War Dancer brutally attacks! Meline took 596 Acid damage!". The line for Meline acquiring the normal version is "Jade Wyrmling casts Slime Wave! Meline took 20 acid damage!"

        Also, some of these status effects don't seem to do much. IIRC when I inflict psychic damage the enemies get a MDF debuff half the time, but they don't take any more damage from later spells on average due to that. I suppose it might effect resistance to other status effects, I haven't tried to analyze statistics on that yet.

        Comment


        • #5
          Minor notes:

          Eulania 3rd heart filled bonus description in followers screen says "Main Character Resist +5", but what I remember the text saying when I got it was resist +3 & 50% resistance to possession. Wiki matches my memory, not the followers screen.

          I haven't found any placement for decorations that makes Apple Kid or Orange Kid happier.

          The secret ladder in the Westfort home, after the quest to acquire it - I can climb down it, even if the bookcase door isn't open, and I can open the bookcase door, but I cannot go up it anymore.

          (I've updated some of the earlier posts for details I've noticed since original postings)

          edit: 1.4 million sil for the candy factory sounds pretty ridiculous. There's no way I can get that kind of money without cheating. I can't even get close. Well... I haven't seen some of the newer quests yet, if they're extremely lucrative there's a chance, but I think they'd need to give about a million sil or close to it. Also, I'm not too sure about the Orange Girl investment being mandatory - the money it earns is barely more than the bank, and it stops earning money while I'm on vacation, unlike the bank.
          Last edited by scro; 09-01-2019, 05:52 AM.

          Comment


          • #6
            Thanks for your reports, I am keeping up with them and appreciate them, just have not had the time to fix them quite yet.

            Originally posted by scro View Post
            edit: 1.4 million sil for the candy factory sounds pretty ridiculous. There's no way I can get that kind of money without cheating. I can't even get close. Well... I haven't seen some of the newer quests yet, if they're extremely lucrative there's a chance, but I think they'd need to give about a million sil or close to it.
            We have actually gotten confirmation that it is possible without cheating over the course of a single playthrough. While it does require a lot of effort, you can in fact afford it with the game in it's current state.

            Comment


            • #7
              In Cannibal Corpse, after killing off the demon and getting my paperwork signed (which is ridiculous... I'm an adventurer, that wasn't what I was hired for, was it? why wasn't my paperwork signed after clearing the sewers?), I can no longer save. That's fixed when I go to the guild and get my reward, but not being able to save while having full access to the general map seems wrong.

              Comment


              • #8
                Talking to Kyrie in the southport home produces "I guess we'll never run out of swords in this place....", which sounds like it was intended for the Eastfort home instead.

                edit:
                Beach vacation dialogue with Bronwyn looks to have been written before the MC's clothing changed for the beach.
                Last edited by scro; 09-02-2019, 12:10 PM.

                Comment


                • #9
                  H-scene with Randi on vacation, several of her dialogue panels have her not wearing her collar.

                  Comment


                  • #10
                    random quest map:
                    It's a map where there's some water you can walk in that hurts you. Immediately north of the water is a wall with some green stains and some vines. The green stains can (incorrectly) be walked into, while the vines and the unmarked wall squares can't.

                    typos:
                    Larelle, speaking of the clockwork girl quest: "I never figured you to be the tyope for sex toys."
                    Elaiya, speaking about Eulania from the harem dialogue, I went through it pretty fast but I thought I saw a semicolon incorrectly placed in the middle of the dialogue.
                    Elaiya, speaking about the Sacrifices for Algernon quest, "I best Masterw ould pact with a demon in order to get a harem girl...."

                    Comment


                    • #11
                      In the university, in the left wing, the signs by the doors, the sign for the Arcanophilosophy Deparment has the wrong title for it's dean.

                      edit:
                      MC, talking to the blue-haired shopkeeper / mom in Eastfort: "I should Elaiya in on that, too. Like a sexy bluepalooza."
                      should Elaiya -> should get Elaiya
                      Last edited by scro; 09-07-2019, 04:35 PM.

                      Comment


                      • #12
                        On loading a saved game, I just found Felix in my party. I'm pretty sure I didn't put him there. I've seen that happen before. The save was during the Shipping Disaster quest, but I think the more common element is that it tends to happen shortly after the Elaiya LQ.

                        BUG: Doing Shipping Disaster, Alina got in to battle with Doralice, I went in to item menu to use an item, got a message about lack of training, pressed the cancel button, cancel sound effect played, and then all menus disappeared, the game no longer responds to regular controls (though F1 etc still works), I had to quit.

                        Larelle love quest doesn't update her followers profile (other LQs do, at least some of them).

                        typo: Dialogue for starting Shipping Disaster quest, Florine says "What adventurer's don't need in Westcastle [blah blah blah]", the apostrophe there is incorrect, it's not a possessive.

                        edit: Also, during Shipping Disaster there was no ability to save, so after I had to quit my last save was before entering the tower thingy.
                        Last edited by scro; 09-10-2019, 12:31 PM.

                        Comment


                        • #13
                          And after having to start Shipping Disaster over from the start of the tower, 15 minutes to get through it again (though it would have been a lot faster if I surrendered instead of fighting the persistent guards - Larelle was regenerating mana and capable of killing all of them with a single Eternal Nightmare, and acting before them most of the time), get through the mansion again, and bam, game crashes as soon as I enter battle again. I am not a happy camper.

                          edit: Okay, I can turn back in the tower prior to end, so I can kill everyone killable and then save outside the tower, that cuts things down a little. Doesn't help with repeating the cutscenes though.

                          edit2: Okay, finally completed the mission without any crashes or lockups. I avoided holding down control the next time I encountered Doralice, figured that might have contributed to the issue the 2nd time. Got the praise section. Still can't open up a menu though... fingers crossed that will be fixed soon.

                          edit3: Whew, menus started working again after praising. I praised the 3 girls the walkthrough said to praise - I wanted to praise others, since those three are already maxed out, but the walkthrough specifically said to praise those three and I wasn't daring to take any risks by that point.

                          edit4: No wait, spoke to soon - party got reset to include Elaiya and Felix again.
                          Last edited by scro; 09-10-2019, 01:21 PM.

                          Comment


                          • #14
                            Are You Afraid Of The Dark: Um... I guess the dark part was okay during the quest, but the lights did not turn back on afterwards. I'll try doing it again from the begining.

                            Comment


                            • #15
                              Circle of Strife: the adventurer's guild interior during this uses the old style of notice board.

                              edit:
                              Also, those mercenaries you funded? I don't think their camp showed up until after Circle of Strife, despite the guy telling you they were there way before then. And now that they have showed up, they tell me they don't have work and can't pay me back, though it's now after Circle of Strife any my daily income went up so I think they are paying me, and they really ought to have work.

                              Messing with their formations was fun though.
                              Last edited by scro; 09-10-2019, 06:48 PM.

                              Comment

                              Working...
                              X